Autore Topic: OpenWRT on Fonera  (Letto 62639 volte)

hunterbit

  • Novellino
  • *
  • Post: 34
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #360 il: Luglio 06, 2008, 03:56:43 pm »
beh...allora devo provare a trovare qualcosa...nel caso mi sa che passo a DD-WRT che anche se magari instabile ma almeno funziona
e sfrutto le fonera...altrimenti soldi buttati :-(

crisman

  • Jr. Member
  • **
  • Post: 66
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #361 il: Luglio 11, 2008, 03:57:26 pm »
allora per quanto riguarda la fonera plus (2201) il supporto in openwrt ? stato aggiunto a partire dalla revision 10877. Quindi se vuoi usare Openwrt con la tua fonera 2201 devi compilarti il firmware a mano, o recuperare uno gi? compilato da svn. Va bene qualsiasi firmware con revisione superiore a 10877 ;)

hunterbit

  • Novellino
  • *
  • Post: 34
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #362 il: Luglio 13, 2008, 02:53:33 pm »
beh vedr? di fare una ricerca per caire come si fa ? metter? in pratica il tuo consiglio.
Grazie di tutto.

Ramponis

  • Hero Member
  • *****
  • Post: 1062
    • Mostra profilo
    • DWL-2100AP Ramponis Homepage
Re: OpenWRT on Fonera
« Risposta #363 il: Luglio 14, 2008, 09:22:17 am »
Sto compilando ora la r11818 appena ? pronta la metto on-line sul solito ftp  :wink:
DWL-2100AP Ramponis Homepage
http://xoomer.alice.it/ramponis/

truthahn

  • Global Moderator
  • Hero Member
  • *****
  • Post: 1546
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #364 il: Luglio 15, 2008, 06:53:25 pm »
Mi date una mano? non ho capito come impostare un link tra due classi di indirizzi con openwrt e fonera:

(82.186.215.211 Fonera Ap)------------------(Fonera CL 192.168.1.x)___pc




Fabietto_DJ

  • Full Member
  • ***
  • Post: 209
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #365 il: Luglio 15, 2008, 09:30:32 pm »
Ecco si l'argomento mi interessa anche a me...

truthahn

  • Global Moderator
  • Hero Member
  • *****
  • Post: 1546
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #366 il: Luglio 17, 2008, 07:10:13 pm »
Mi date una mano? non ho capito come impostare un link tra due classi di indirizzi con openwrt e fonera:
(82.186.215.211 Fonera Ap)------------------(Fonera CL 192.168.1.x)___pc
TROVATO!! :-D non so se si possa fare diversamente e meglio ma funzia. Sto scrivendo da un link come sopra.

Configurazioni:
Fonera Client
Codice: [Seleziona]
root@OpenWrt:~# cat /etc/config/network
# Copyright (C) 2006 OpenWrt.org

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface wan
        option ifname   ath0
        option proto    static
        option ipaddr   10.10.10.2
        option netmask  255.255.255.0
        option gateway  '10.10.10.1'

config interface lan
       option ifname    eth0
       option proto  static
       option ipaddr  192.168.1.1
       option netmask 255.255.255.0

root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  wifi0
option type     atheros
option mode '11bg'
option diversity '0'
option disabled '0'
option distance '100'



config wifi-iface
option device wifi0
option network wan
option mode 'sta'
option ssid 'NabukF'
option encryption 'psk2'
option hidden '0'
option isolate '0'
option txpower '18'
option bgscan '0'
option wds '1'
option key 'hhhhhh'

Fonera Ap

Codice: [Seleziona]
root@OpenWrt:~# cat /etc/config/network
# Copyright (C) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface wan
option ifname eth0
option proto static
        option ipaddr      192.168.60.144
option netmask 255.255.255.240
        option gateway  192.168.60.1
        option dns      212.216.112.112

config interface lan
option ifname ath0
option proto static
option ipaddr 10.10.10.1
option netmask 255.255.255.0

root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  wifi0
        option type      atheros
        option channel   11
        option diversity 0
        option txantenna 1
        option rxantenna 1
        option distance  100
        option disabled  0
option mode '11bg'

config  wifi-iface
option device wifi0
        option network lan
option txpower 17
        option bgscan 0
option mode ap
        option wds 1
        option hidden 0
        option isolate 0
option ssid NabukF
option encryption 'psk2'
option key 'hhhhhh'

root@OpenWrt:~# cat /etc/firewall.user
#!/bin/sh
# Copyright (C) 2006 OpenWrt.org

iptables -F input_rule
iptables -F output_rule
iptables -F forwarding_rule
iptables -t nat -F prerouting_rule
iptables -t nat -F postrouting_rule

# The following chains are for traffic directed at the IP of the
# WAN interface

iptables -F input_wan
iptables -F forwarding_wan
iptables -t nat -F prerouting_wan


iptables -t nat -A prerouting_wan -p tcp --dport 22 -j ACCEPT
iptables        -A input_wan      -p tcp --dport 22 -j ACCEPT
iptables -t nat -A prerouting_wan -p tcp --dport 80 -j ACCEPT
iptables        -A input_wan      -p tcp --dport 80 -j ACCEPT


ip eth0 del pc: 192.168.1.12/24
gateway pc: 192.168.1.1
Tutto al tavolo. poi dovr? mettere sull'ap un indirizzo pubblico.  Consigli pi? raffinati?
« Ultima modifica: Luglio 17, 2008, 10:23:34 pm da truthahn »

truthahn

  • Global Moderator
  • Hero Member
  • *****
  • Post: 1546
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #367 il: Luglio 18, 2008, 03:09:13 pm »
Come da configurazione sopra riportata ho realizzato il link tra una scuola e la biblioteca. La scuola mi ha dato un ip pubblico ma non mi ha fatto passare per il suo firewall, quindi fonera come firewall e con ip pubblico, biblio in nat. 600 m.  Due yagi. Fatto stamattina sotto un temporale, ancora provvisorio sul tetto della biblio causa diluvio. Luned? si finisce. Intanto tutto funziona ( Signal level=-74 dBm  Noise level=-96 dBm) anche se sicuramente migliorer? con un puntamento pi? preciso . Bagnato fradicio ma felice :-D.
« Ultima modifica: Febbraio 22, 2010, 10:48:52 am da truthahn »

truthahn

  • Global Moderator
  • Hero Member
  • *****
  • Post: 1546
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #368 il: Luglio 18, 2008, 03:35:09 pm »
Domanda: dove sta, se ci sta, il file di configurazione di sshd su openwrt? Vorrei cambiare la porta.

crisman

  • Jr. Member
  • **
  • Post: 66
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #369 il: Luglio 18, 2008, 04:32:03 pm »
Si trova nel file /etc/config/dropbear.

Codice: [Seleziona]
config dropbear
option PasswordAuth 'on'
option Port         '22'

Naturalmente se cambi la porta devi anche cambiare la regola nel firewall nel caso volessi accedere in ssh da remoto   :wink:

truthahn

  • Global Moderator
  • Hero Member
  • *****
  • Post: 1546
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #370 il: Luglio 18, 2008, 05:22:21 pm »
Grasssssie!!!
Altra domanda: creare utenti ? possibile in qualche modo? e il comando "su"? Sempre per l'ssh.

Ramponis

  • Hero Member
  • *****
  • Post: 1062
    • Mostra profilo
    • DWL-2100AP Ramponis Homepage
Re: OpenWRT on Fonera
« Risposta #371 il: Ottobre 29, 2009, 03:31:42 pm »
Citazione
creare utenti ? possibile in qualche modo?

Certo edita il file /etc/password

Io copio l'utente root e poi modifico la password del nuovo utente col comando:

passwd user password

dove user e il nome utente che scrivi nel file /etc/password

e pasword ? la nuova password scelta per quell'utente

Citazione
e il comando "su"?

Non mi sembra...  :roll:
DWL-2100AP Ramponis Homepage
http://xoomer.alice.it/ramponis/

obaoba

  • Novellino
  • *
  • Post: 26
    • Mostra profilo
Re: OpenWRT on Fonera
« Risposta #372 il: Novembre 17, 2009, 04:50:57 pm »
son dentro il fonera in ssh

perch? non mi riconosce il comando ipkg?

root@OpenWrt:~# ipkg list_installed
-ash: ipkg: not found

p.s ho la versione 8 del  KAMIKAZE
« Ultima modifica: Novembre 17, 2009, 04:53:00 pm da obaoba »

Ramponis

  • Hero Member
  • *****
  • Post: 1062
    • Mostra profilo
    • DWL-2100AP Ramponis Homepage
Re: OpenWRT on Fonera
« Risposta #373 il: Novembre 17, 2009, 05:50:18 pm »
La versione 8 non usa pi? ipkg... ma usa opkg  :wink:
DWL-2100AP Ramponis Homepage
http://xoomer.alice.it/ramponis/

BigLouis87

  • Novellino
  • *
  • Post: 15
    • Mostra profilo
    • Forza Virtus! La community della Virtus Basket Civitanova
Re: OpenWRT on Fonera
« Risposta #374 il: Dicembre 21, 2009, 07:18:28 pm »
ragazzi... domandona:
ho una 2100 (si, le "fornetto" editions!) e sto cercando da settimane di utilizzarla come ap connesso ad un modem con pppoe.
Riesco a farla funzionare sia con dd-wrt (provate 24 e 24sp2) sia con openwrt (8.04 e 8.04 rc2), ma con tutte e due se accendo emule anche su un solo pc dopo qualche minuto la fonera si riavvia!! :-o
Ho pensato a un problema di surriscaldamento, cos? ho tolto la scocca e la faccio funzionare "nuda", ma anche essendo pi? fresca continua a riavviarsi.... premetto che l'ho usata per due anni come client e non mi ha mai dato problemi.
Pu? essere un problema di firmware? magari la vecchia versione 7.04 di openwrt ? supportata meglio?

vi chiedo una mano, altrimenti la fonera ? inutilizzabile... :cry:

grazie
Sia Linux che Windows si inspirano alle massime del grande Albert Einstein:
Linux: "La mente ? come un paracadute. Funziona solo se si apre."
Windows: "Il segreto della creativit? ? saper nascondere le proprie fonti."